[C_AR192-易] 判断任意字串中的字元是否有重複
Time Limit: 2 seconds
問題描述 :
判断任意字串中的字元是否有重複
輸入說明 :
輸入任意字串
1≤字串長度≤30
輸出說明 :
字串中的字元無重複 : true
字串中的字元有重複 : false
範例 :
問題描述 :
判断任意字串中的字元是否有重複
輸入說明 :
輸入任意字串
1≤字串長度≤30
輸出說明 :
字串中的字元無重複 : true
字串中的字元有重複 : false
範例 :
Sample Input: | Sample Output: |
34567 | true |
- #include <iostream>
- using namespace std;
- int main() {
- // [C_AR192-易] 判断任意字串中的字元是否有重複
- string test;
- getline(cin, test);
- int array[2000];
- for(int i = 0;i < 2000;i++)
- {
- array[i] = 0;
- }
- for(int i = 0;i < test.size();i++)
- {
- array[(int)test[i]]++;
- }
- bool re = true;
- for(int i = 0;i < 2000;i++)
- {
- if(array[i] > 1)
- {
- re = false;
- }
- }
- if(re == false)
- cout << "false" << endl;
- else
- cout << "true" << endl;
- return 0;
- }
沒有留言:
張貼留言