2017年3月15日 星期三

[UVA]10041:Vito's family

Time Limit: 3 sec
Background
The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.
Description
Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.
Input
The input consists of several test cases. The first line contains the number of test cases.
For each test case you will be given the integer number of relatives r ( 0r < 500) and the street numbers (also integers)   where they live ( 0 < si < 30000 ). Note that several relatives could live in the same street number.
Output
For each test case your program must write the minimal sum of distances from the optimal Vito's house to each one of his relatives. The distance between two street numbers si and sj is dij= |si-sj|.



Sample Input
Sample Output
2
2 2 4
3 2 4 6
2
4


import java.util.*;

public class main {
    public static void main(String[] args) {

    Scanner sc = new Scanner(System.in);
    int test_time = sc.nextInt();   //輸入測試次數

    for (int c=0; c<test_time; c++)
    {
         int[] r = new int[sc.nextInt()];  //輸入親戚數量
         for (int i=0; i<r.length; i++)
         {
               r[i] = sc.nextInt();   //輸入親戚住在哪條街上
         }

         Arrays.sort(r);  //排序( Array.sort() ),將號碼從小排到大
         int m = r[r.length/2];  //找出陣列中點

         int sum=0;
         for (int i=0; i<r.length; i++)
         {
              sum = sum + Math.abs(r[i]-m); // Math.abs絕對值
         }
         System.out.println(sum);
         }
     }
}

沒有留言:

張貼留言