2017年3月15日 星期三

[UVA]10055:Hashmat the brave warrior

Time Limit: 3 sec
Description
Hashmat is a brave warrior who with his group of young soldiers moves from one place to another to fight against his opponents. Before fighting he just calculates one thing, the difference between his soldier number and the opponent's soldier number. From this difference he decides whether to fight or not. Hashmat's soldier number is never greater than his opponent.
Input
The input contains two integer numbers in every line. These two numbers in each line denotes the number of soldiers in Hashmat's army and his opponent's army or vice versa. The input numbers are not greater than 2^32. Input is terminated by End of File.
Output
For each line of input, print the difference of number of soldiers between Hashmat's army and his opponent's army. Each output should be in seperate line.

Sample Input
Sample Output
Sample IO Generation
10 12
10 14
100 200
2
4
100


計算兩軍隊的兵力差,因為"The input numbers are not greater than 2^32,所以要用long才不會溢位

import java.util.*;

public class main{
    public static void main(String arge[]){
        Scanner sc = new Scanner(System.in);
        long x, y;
        
        while(sc.hasNext())
        {
            x = sc.nextLong();
            y = sc.nextLong();
        
            System.out.println(Math.abs(x-y));
        }
    
    }
}

沒有留言:

張貼留言