[C_MM225-易] 不能吵架辣
有一對好朋友吵架了,因為他們之後分東西的時候,不管怎麼樣都算不好。他們買之前已經先說好,每個人每次都分兩個蛋糕和一杯飲料直到分完為止,可是在買的時候才發現每買三個蛋糕或兩杯飲料,老闆就會送一包小餅乾。出乎意料的他們,決定說餅乾就每次一人分一包吧。請問一下,他們在怎麼樣買的情況下可以很公平的分完,讓兩個好朋友不會吵架。當兩個數量輸入都為 -1 時結束程式。
輸入格式
兩個正整數 m ,n 。 m 代表買多少個蛋糕 , n 代表買了多少飲料。
輸出格式
能公平的依規則分,則輸出 yes
無法公平的依規則分,則輸出 no
Sample input
4 2
2 1
-1 -1
Sample output
yes
no
輸入格式
兩個正整數 m ,n 。 m 代表買多少個蛋糕 , n 代表買了多少飲料。
輸出格式
能公平的依規則分,則輸出 yes
無法公平的依規則分,則輸出 no
Sample input
4 2
2 1
-1 -1
Sample output
yes
no
- #include <iostream>
- #include <cmath>
- using namespace std;
- int main() {
- // [C_MM225-易] 不能吵架辣
- int cake, drink, cookie;
- while(cin >> cake >> drink)
- {
- if(cake != -1 && drink != -1)
- {
- cookie = floor(cake/3) + floor(drink/2);
- if(cake%4==0 && drink%2==0 && cookie%2==0&&(cake/4==drink/2))
- {
- cout << "yes" << endl;
- }
- else
- {
- cout << "no" << endl;
- }
- }
- else
- {
- break;
- }
- }
- return 0;
- }
沒有留言:
張貼留言