[C_ST02-易] 迴文字串
Problem Description
給予一個英文字母與數字參雜的字串,長度限制在 256 個字母內。請撰寫一程式輸出此字串的迴文字串。
Input File Format
輸入分為兩部份,第一行是介於 1 到 99 的數字,表示接著有幾個要輸入的字串。第二部份是所要改變的字串,每個字串單獨佔一列。
Output Format
經轉換後的迴文字串。
Example
給予一個英文字母與數字參雜的字串,長度限制在 256 個字母內。請撰寫一程式輸出此字串的迴文字串。
Input File Format
輸入分為兩部份,第一行是介於 1 到 99 的數字,表示接著有幾個要輸入的字串。第二部份是所要改變的字串,每個字串單獨佔一列。
Output Format
經轉換後的迴文字串。
Example
Sample Input: | Sample Output: |
3 bcd12345 0987654321 0a1b2c3d4e5f6g | 54321dcb 1234567890 g6f5e4d3c2b1a0 |
- #include <iostream>
- #include <cmath>
- #include <string.h>
- using namespace std;
- int main() {
- // [C_ST02-易] 迴文字串
- int n,count;//n是測資數
- char change;//互換的暫存值
- cin >> n;
- string input;
- for(int j = 0;j < n;j++)
- {
- cin >> input;
- count = input.size();//string 長度
- char result[count]; //存入回文結果
- strcpy(result, input.c_str());//string to char
- for(int i = 0;i<floor(count/2);i++)//製造回文
- {
- change = result[i];
- result[i] = result[count-1-i];
- result[count-1-i] = change;
- }
- for(int i = 0;i<count;i++)//輸出
- {
- if(i == count-1)
- {
- cout << result[i] << endl;
- }
- else
- {
- cout << result[i];
- }
- }
- }
- return 0;
- }
沒有留言:
張貼留言