[C_ST33-易] 英文字的分數
問題描述:
前陣子很流行一個勵志遊戲,把所有的英文字母,轉成分數來看, a 算 1 、 b 算 2 、 c 算 3 、以此類推下去,例如; attitude ( 態度 ) 為 100 分 (1+20+20+9+20+21+4+5) , talent( 天才 ) 為 72 分 (20+1+12+5+14+20)
輸入說明:
輸入一個英文單字
輸出說明:
輸出一個數字
範例:
前陣子很流行一個勵志遊戲,把所有的英文字母,轉成分數來看, a 算 1 、 b 算 2 、 c 算 3 、以此類推下去,例如; attitude ( 態度 ) 為 100 分 (1+20+20+9+20+21+4+5) , talent( 天才 ) 為 72 分 (20+1+12+5+14+20)
輸入說明:
輸入一個英文單字
輸出說明:
輸出一個數字
範例:
Sample Input | Sample Output |
attitude | 100 |
- #include <iostream>
- #include <ctype.h>
- #include<string>
- #include <stdio.h>
- #include <string.h>
- using namespace std;
- int main() {
- // [C_ST33-易] 英文字的分數
- string text;
- int grade = 0;
- getline(cin, text);
- char chText[text.size()];
- strcpy(chText, text.c_str());
- for(int i = 0;i < text.size();i++)
- {
- chText[i] = tolower(chText[i]);
- grade = grade + (chText[i]-96);
- }
- cout << grade << endl;
- return 0;
- }
沒有留言:
張貼留言