[C_MM44-易] The Numbers
問題描述:請寫一個程式,判斷一個數字N出現在另外一個數字M中的次數。
10 ≤ N ≤ 99,1000000 ≤ M ≤ 9999999
輸入說明 : 輸入資料有兩個整數,N和M。
輸出說明 : 輸出為一整數,也就是N出現在M裡面的次數。
範例 :
Sample Input: | Sample Output: |
90 9090999 11 1110111 | 2 4 |
- #include<iostream>
- #include<string>
- using namespace std;
- int main()
- {
- //[C_MM44-易] The Numbers
- //判斷一個數字N出現在另外一個數字M中的次數
- //N第一個數字和M第一個數字相同時count+1
- //N第二個數字和M第二個數字相同時count+1
- //count == N的長度時
- //代表與N相同,所以times+1
- string N, M;
- while(cin >> N >> M)
- {
- int times = 0;//計算重複次數
- for(int i=0; i < M.length();i++)
- {
- int count = 0;
- //逐一比較次數
- for(int j = 0;j < N.length();j++)
- {
- if(M[i+j] == N[j] && i+j < M.length())
- {
- count++;
- }
- else
- {
- break;
- }
- }
- if(count == N.length())
- {
- times++;
- }
- }
- cout << times << endl;
- }
- }
沒有留言:
張貼留言