**如果看不懂可以在底下留言發問**
**試著看懂別人的程式碼也是一種學習^ ^**
[C_ST31-易] 移除字串中的空白鍵和定位鍵
問題描述 :
給予一字串,其中包括英文大小寫字母、定位鍵與空白鍵。英文單字是以空白鍵分隔開。請刪除所有定位鍵與空白鍵後輸出只包含大小寫字母的英文字串。
輸入說明 :
輸入為長度在128個字母內的字串。
輸出說明 :
刪除所有定位鍵與空白鍵後的字串。
範例 :
給予一字串,其中包括英文大小寫字母、定位鍵與空白鍵。英文單字是以空白鍵分隔開。請刪除所有定位鍵與空白鍵後輸出只包含大小寫字母的英文字串。
輸入說明 :
輸入為長度在128個字母內的字串。
輸出說明 :
刪除所有定位鍵與空白鍵後的字串。
範例 :
Sample Input: | Sample Output: |
Clothes make the man. Don't judge a book by its cover. | Clothesmaketheman.Don'tjudgeabookbyitscover. |
- #include <iostream>
- #include <string.h> //strcpy()
- using namespace std;
- int main() {
- // [C_ST31-易] 移除字串中的空白鍵和定位鍵
- string text;
- getline(cin, text);//使用者輸入(整行讀取包含空白)
- int count = text.size();//string 長度
- char result[count]; //存入結果
- strcpy(result, text.c_str());//string to char
- for(int i = 0;i < count;i++)
- {
- if(result[i] != 32 && result[i] != 9) //不是空白也不是Tab
- {
- if(i == count-1)
- {
- cout << result[i] << endl;
- }
- else
- {
- cout << result[i];
- }
- }
- }
- return 0;
- }
沒有留言:
張貼留言